Machine image v6.6.4 (Docker TAG v6.6.4)

Release Date: June 28, 2018

What is installed on the machine image?

u14 sku

  • Host Operating System: Ubuntu 14.04 LTS
  • Build Container Operating System: Ubuntu 16.04.3 LTS
  • Kernel Version: 3.13.0-125-generic
  • Docker Server Version: 17.06.0-ce
  • Storage Driver: aufs
  • Root Dir: /data/aufs
  • Backing Filesystem: extfs
  • Dirperm1 Supported: false
  • Cgroup Driver: cgroupfs
  • Shippable Official u14 and u16 Docker Images with TAG: v6.6.4

u16 sku

  • Host Operating System: Ubuntu 16.04 LTS
  • Build Container Operating System: Ubuntu 16.04.3 LTS
  • Kernel Version: 4.4.0-1049-aws
  • Docker Server Version: 17.06.0-ce
  • Storage Driver: aufs
  • Root Dir: /data/aufs
  • Backing Filesystem: extfs
  • Dirperm1 Supported: false
  • Cgroup Driver: cgroupfs
  • Shippable Official u16 Docker Images with TAG: v6.6.4

c7 sku

  • Host Operating System: CentOS 7
  • Build Container Operating System: CentOS 7
  • Kernel Version: 3.10.0-514.10.2.el7.x86_64
  • Docker Server Version: 17.06.0-ce
  • Storage Driver: overlay
  • Root Dir: /data
  • Backing Filesystem: xfs
  • Cgroup Driver: cgroupfs
  • Shippable Official c7 Docker Images with TAG: v6.6.4

w16 sku

  • Host Operating System: Windows Server 2016 Datacenter Edition (Version 1607)
  • Build Container Operating System: Windows Server Core 2016 v10.0.14393.1884
  • Docker Server Version: 17.06.2-ee-5
  • Shippable Official w16 Docker Images with TAG: v6.6.4

Shippable Official Docker Images

These are the images used to run your CI jobs. The default image is picked up based on the language you set in your yml. All these images are available on our Docker drydock Hub. The source code is available in our GitHub dry-dock org

If you would like to use your own CI images in place of the official images, instructions are described here

These are the official language images in this version:

Common components

All language images are built FROM a base image that corresponds to the OS version. For example, the language image for Node,js u16nodall is built using u16all as the base image, and hence has all the packages, CLIs and services installed in the base image.

We have the following base images, one for each supported OS version.

OS Image Link Packages CLIs Services
Ubuntu 16.04 drydock/aarch32_u16:v6.6.4 - Docker Hub
- GitHub
- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- boto
- boto3
- virtualenv
- wget
- libssl-dev
-libffi-dev
-vim
- awscli 1.15.3
- awsebcli 3.12.4
- gcloud 196.0.0
- kubectl 1.9.0
- packer 1.2.2
- ansible 3.0.0
Ubuntu 14.04 drydock/u14all:v6.6.4 - Docker Hub,
- GitHub

- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- zip
- virtualenv
- wget
- vim
- groff
- rsync
- awscli 1.15.14
- awsebcli 3.12.4
- gcloud 200.0.0
- jfrog-cli 1.15.1
- kubectl 1.10.0
- packer 1.2.3
- ansible 2.5.2
- terraform 0.11.7
- azure 2.0.37
- cassandra 3.11.2
- couchdb 2.1.1
- elasticsearch 6.2.4
- neo4j 3.3.5
- memcached 1.5.7
- mongodb 3.6.4
- mysql 5.7.22
- postgres 10.4
- rabbitmq 3.6.15-1
- redis 4.0.10
- riak 2.2.3
- selenium 3.11.0
- sqllite 3.22.0
Ubuntu 16.04 drydock/u16all:v6.6.4 - Docker Hub,
- GitHub
- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- zip
- virtualenv
- wget
- apt-transport-https 1.2.26
- awscli 1.15.14
- awsebcli 3.12.4
- gcloud 200.0.0
- jfrog-cli 1.15.1
- kubectl 1.10.0
- packer 1.2.3
- ansible 2.5.2
- terraform 0.11.7
- azurecli 2.0.37
- cassandra 3.11.2
- couchdb 2.1.1
- elasticsearch 6.2.4
- neo4j 3.3.5
- memcached 1.5.7
- mongodb 3.6.4
- mysql 5.7.22
- postgres 10.4
- rabbitmq 3.6.15
- redis 4.0.10
- riak 2.2.3
- selenium 3.11.0
- sqllite 3.22.0
Ubuntu 16.04 drydockaarch64/u16all:v6.6.4 - Docker Hub,
- GitHub
- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- zip
- virtualenv
- wget
- awscli 1.15.14
- awsebcli 3.12.4
- gcloud 200.0.0
- kubectl 1.10.0
- packer 1.2.2
- azure 3.0.0
- couchdb 1.6.0
- elasticsearch 6.2.4
- memcached 1.4.25
- mongo 3.6.4
- neo4j 3.3.5
- postgres 9.5.13
- rabbitmq 3.6.15
- redis 4.0.10
- selenium 3.11.0
- sqlite 3.11.0
CentOS 7 drydock/c7all:v6.6.4 - Docker Hub,
- GitHub
- epel-release
- gcc
- gcc-c++
- kernel-devel
- make
- curl
- openssl
- wget
- unzip
- zip
- nano
- openssh-clients
- htop
- rsync
- vim
- glibc.i686
- libgcc_s.so.1
- python36u
- python36u-libs
- python36u-devel
- python36u-pip
- virtualenv
- jq
- git
- git-lfs
- awscli 1.15.14
- gcloud 200.0.0
- kubectl 1.10.0
- doctl 1.8.0
- jfrog-cli 1.15.1
- ansible 2.5.2
- boto 2.48.0
- apache libcloud 2.3.0
- terraform 0.11.7
- packer 1.2.3
- azure-cli 2.0.37
- Cassandra 3.11.2
- MemCached 1.5.7
- LibMemCached 1.0.18
- Mongodb 3.6.4
- Neo4j 3.3.5
- RabbitMQ 3.6.15
- Redis-server 4.0.9
- ElasticSearch 6.2.4
- Riak 2.2.3
- Selenium 3.11.0
- Sqlite 3.22.0
- mysql 5.7.22
- postgres 10.4
- couchdb 2.1.1
Windows 16 drydock/w16:v6.6.4 - Docker Hub,
- GitHub
- git 2.17.1
- git-lfs 2.4.0
- gcloud 206.0.0
- awscli 1.15.41
- Azurecli 2.0.37
- kubectl 1.10.4
- jfrog-cli 1.11.2
- terraform 0.11.7
- packer 1.2.4
- jq 1.5.0

Node.js

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16nodall:v6.6.4 Docker Hub
GitHub
- 6.14.3
- 8.11.3
- 9.11.2
- 10.1.0
Common components
nvm
Java 1.8.0
Ruby 2.5.1
Yarn 1.6.0
Ubuntu 16.04 (aarch64) drydockaarch64/u16nodall:v6.6.4 Docker Hub
GitHub
- 6.14.3
- 8.11.3
- 9.11.2
- 10.1.0
Common components
nvm
Java OpenJDK 1.8.0
Ruby 2.5.1
Yarn 1.6.0
Ubuntu 14.04 drydock/u14nodall:v6.6.4 Docker Hub
GitHub
- 6.14.3
- 8.11.3
- 9.11.2
-10.1.0
Common components
nvm
Java 1.8.0
Ruby 2.5.1
Yarn 1.6.0
CentOS 7 drydock/c7nodall:v6.6.4 Docker Hub
GitHub
- 6.14.2
- 8.11.2
- 9.11.1
- 10.2.1
Common components
nvm
Java 1.8.0
Ruby 2.5.1
Yarn 1.6.0

Clojure

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16cloall:v6.6.4 - Docker Hub,
- GitHub
- 1.3.0
- 1.4.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.8.0
- 1.9.0
- Common components
- leiningen
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14cloall:v6.6.4 - Docker Hub,
- GitHub
- 1.3.0
- 1.4.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.8.0
- 1.9.0
- Common components
- leiningen
- Java 1.8
- Node 8.11.3
- Ruby 2.5.1

Go

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16golall:v6.6.4 - Docker Hub
- GitHub
- 1.7.6
- 1.8.7
- 1.9.6
- 1.10.2
- Common components
- gvm 1.10.2
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14golall:v6.6.4 - Docker Hub
- GitHub
- 1.7.6
- 1.8.7
- 1.9.6
- 1.10.2
- Common components
- gvm 1.10.2
- Java 1.8
- Node 8.11.3
- Ruby 2.5.1

PHP

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16phpall:v6.6.4 - Docker Hub,
- Github
- 5.6.36
- 7.0.30
- 7.1.18
- 7.2.6
- Common components
- phpenv 1.1.1-2-g615f844
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14phpall:v6.6.4 - Docker Hub,
- Github
- 5.6.36
- 7.0.30
- 7.1.18
- 7.2.6
- Common components
- phpenv 1.1.1-2-g615f844
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1

Java

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16javall:v6.6.4 - Docker Hub,
- GitHub
- openjdk7
- openjdk8
- openjdk9
- oraclejdk8
- oraclejdk10
- Common components
- Node 8.11.3
- Ruby 2.5.1
- Gradle 4.7
- Maven 3.5.3
- Apache-ant 1.10.3
- Android-sdk 26.0.1 (to be used with openjdk8/oraclejdk8)
Ubuntu 16.04 (aarch64) drydockaarch64/u16javall:v6.6.4 Docker Hub
GitHub
- openjdk7
- openjdk8
- oraclejdk8
Common components
- Node 8.11.3
- Ruby 2.5.1
- Gradle 4.7
- Maven 3.5.3
- Apache-ant 1.10.3
- Android-sdk 26.0.1 (to be used with openjdk8/oraclejdk8)
Ubuntu 14.04 drydock/u14javall:v6.6.4 - Docker Hub
- GitHub
- openjdk7
- openjdk8
- oraclejdk8
- oraclejdk10
- Common components
- Node 8.11.3
- Ruby 2.5.1
- Gradle 4.7
- Maven 3.5.3
- Android-sdk 26.0.1 (to be used with openjdk8/oraclejdk8)
CentOS 7 drydock/c7javall:v6.6.4 - Docker Hub
- GitHub
- openjdk7
- openjdk8
- openjdk9
- oraclejdk8
- oraclejdk10
- Common components
- Node 8.11.2
- Ruby 2.5.1
- Gradle 4.7
- Maven 3.5.3
- Android-sdk 26.0.1 (to be used with openjdk8/oraclejdk8)

Ruby

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16ruball:v6.6.4
- Docker Hub,
- GitHub
- 2.2.10
- 2.3.7
- 2.4.4
- 2.5.1
- jruby-1.7.27
- jruby-9.1.17.0
- Common components
- rvm 2.5.1
- Java 1.8.0
- Node 8.11.3
Ubuntu 14.04 drydock/u14ruball:v6.6.4
- Docker Hub,
- GitHub
- 2.2.10
- 2.3.7
- 2.4.4
- 2.5.1
- jruby-1.7.27
- jruby-9.1.17.0
- Common components
- rvm 2.5.1
- Java 1.8.0
- Node 8.11.3

Python

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16pytall:v6.6.4 - Docker Hub
- GitHub
- 2.7.12
- 3.6.5
- pypy2 5.10.0
- pypy3 5.10.1
- Common components
- virtualenv
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 16.04 (aarch64) drydockaarch64/u16pytall:v6.6.4 - Docker Hub
- GitHub
- 2.7.12
- 3.6.5
Common components
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14pytall:v6.6.4 - Docker Hub
- GitHub
- 2.7.12
- 3.6.5
- pypy2 5.10.0
- pypy3 5.10.1
- Common components
- virtualenv
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
CentOS 7 drydock/c7pytall:v6.6.4 - Docker Hub
- GitHub
- 2.7.5
- 3.6.5
- Common components
- virtualenv
- Java 1.8.0
- Node 9.11.1
- Ruby 2.5.1

Scala

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16scaall:v6.6.4 - Docker Hub,
- GitHub

- 2.11.12
- 2.12.6
- Common components
- sbt
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14scaall:v6.6.4 - Docker Hub,
- GitHub
- 2.11.12
- 2.12.6
- Common components
- sbt
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1

C/C++

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16cppall:v6.6.4 - Docker Hub,
- GitHub
- gcc 8.0.1
- clang 6.0.0
- Common components
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 14.04 drydock/u14cppall:v6.6.4 - Docker Hub,
- GitHub
- gcc 8.0.1
- clang 6.0.0
- Common components
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
Ubuntu 16.04 drydockaarch64/u16cppall:v6.6.4 - Docker Hub,
- GitHub
- gcc 8.0.1
- clang 6.0.0
- Common components
- Java 1.8.0
- Node 8.11.3
- Ruby 2.5.1
CentOS 7 drydock/c7cppall:v6.6.4 - Docker Hub,
- GitHub
- gcc 7.3.1
- clang 5.0.1
- Common components
- Java 1.8.0
- Node 9.11.1
- Ruby 2.5.1

Dotnet

OS Image Link Language versions Additional packages
Windows 16 dry-dock/w16dotnetcore:v6.6.4 - Docker Hub,
- GitHub
- .NET Core SDK 2.1.200 - Common components

ASP.Net

OS Image Link Language versions Additional packages
Windows 16 dry-dock/w16aspnetcore:v6.6.4 - Docker Hub,
- GitHub
- ASP.NET Core 2.0.7 - Common components