Machine image v5.8.2 (Docker TAG v5.8.2)

Release Date: August 7, 2017

What is installed on the machine image?

  • Operating System: Ubuntu 14.04.5 LTS
  • Kernel Version: 3.13.0-125-generic
  • Docker Server Version: 17.06.0-ce
  • Storage Driver: aufs
  • Root Dir: /data/aufs
  • Backing Filesystem: extfs
  • Dirperm1 Supported: false
  • Cgroup Driver: cgroupfs
  • Shippable Official Docker Images with TAG: v5.8.2

Shippable Official Docker Images

These are the images used to run your CI jobs. The default image is picked up based on the language you set in your yml. All these images are available on our Docker drydock Hub. The source code is available in our Github dry-dock org

If you would like to use your own CI images in place of the official images, instructions are described here

These are the official language images in this version:

Common components

All language images are built FROM a base image that corresponds to the OS version. For example, the language image for Node,js u16nodall is built using u16all as the base image, and hence has all the packages, CLIs and services installed in the base image.

We have the following base images, one for each supported OS version.

OS Image Link Packages CLIs Services
Ubuntu 16.04 drydock/u16all:v5.8.2 - Docker Hub,
- Github
- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- virtualenv
- wget
- awscli 1.11.91
- awsebcli 3.10.3
- gcloud 165.0.0
- jfrog-cli 1.10.1
- kubectl 1.7.2
- packer 1.0.3
- terraform 0.10.0
- azure 2.10.12
- cassandra 3.11
- couchdb 1.6
- elasticsearch 5.5.1
- neo4j 3.2.3
- memcached 1.5.0
- mongodb 3.4.6
- mysql 5.7.18
- postgres 9.6.3
- rabbitmq 3.6.10
- redis 4.0.1
- rethinkdb 2.3.6
- riak 2.2.3
- selenium 3.4.0
- sqllite 3.19.3
Ubuntu 14.04 drydock/u14all:v5.8.2 - Docker Hub,
- Github

- build-essential
- curl
- gcc
- gettext
- git
- htop
- jq
- libxml2-dev
- libxslt-dev
- make
- nano
- openssh-client
- openssl
- psmisc
- python-dev
- python-pip
- python-software-properties
- software-properties-common
- sudo
- texinfo
- unzip
- virtualenv
- wget
- awscli 1.11.91
- awsebcli 3.10.3
- gcloud 165.0.0
- jfrog-cli 1.10.1
- kubectl 1.7.2
- packer 1.0.3
- terraform 0.10.0
- azure 2.10.12
- cassandra 3.11
- couchdb 1.6
- elasticsearch 5.5.1
- neo4j 3.2.3
- memcached 1.5.0
- mongodb 3.4.6
- mysql 5.6
- postgres 9.6.3
- rabbitmq 3.6.10
- redis 4.0.1
- rethinkdb 2.3.6
- riak 2.2.3
- selenium 3.4.0
- sqllite 3.19.3

Node.js

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16nodall:v5.8.2 Docker Hub
Github
- 4.8.4
- 5.12.0
- 6.11.2
- 7.10.1
- 8.1.4
- 8.2.1
Common components
nvm
Java 1.8.0
Ruby 2.3.3
Yarn 0.24.5
Ubuntu 14.04 drydock/u14nodall:v5.8.2 Docker Hub
Github
4.8.4
5.12.0
6.11.2
7.10.1
8.1.4
8.2.1
Common components
nvm
Java 1.8.0
Ruby 2.3.3
Yarn 0.24.5

Python

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16pytall:v5.8.2 Docker Hub
Github
- 2.7.12
- 3.4.5
- 3.5.2
- 3.6.2
- pypy2 5.8.0
- pypy3 5.8.0
- Common components
- virtualenv
- Java 1.8.0
- Node 7.10.0
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14pytall:v5.8.2 Docker Hub
Github
- 2.7.12
- 3.4.3
- 3.5.3
- 3.6.2
- pypy2 5.8.0
- pypy3 5.8.0
- Common components
- virtualenv
- Java 1.8.0
- Node 4.8.3
- Ruby 2.3.3

Java

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16javall:v5.8.2 - Docker Hub,
- Github
- openjdk7
- openjdk8
- openjdk9
- oraclejdk8
- oraclejdk9
- Common components
- Node 7.10.0
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14javall:v5.8.2
- Docker Hub,
- Github
- openjdk7
- openjdk8
- oraclejdk8
- oraclejdk9
- Common components
- Node 4.8.3
- Ruby 2.3.3

Ruby

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16ruball:v5.8.2 - Docker Hub,
- Github
- 2.2.7
- 2.3.4
- 2.4.1
- jruby 1.7.27
- jruby 9.0.0
- jruby 9.1.12
- Common components
- rvm 1.29.2
- Java 1.8.0
- Node 4.8.3
Ubuntu 14.04 drydock/u14ruball:v5.8.2
- Docker Hub,
- Github
- 2.2.7
- 2.3.4
- 2.4.1
- jruby 1.7.27
- jruby 9.0.0
- jruby 9.1.12
- Common components
- rvm 1.29.2
- Java 1.8.0
- Node 4.8.3

GO

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16golall:v5.8.2 - Docker Hub,
- Github
- 1.7.6
- 1.8.3
- Common components
- gvm 1.0.22
- Java 1.8.10
- Node 4.8.3
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14golall:v5.8.2 - Docker Hub,
- Github
- 1.7.6
- 1.8.3
- Common components
- gvm 1.0.22
- Java 1.8.10
- Node 4.8.3
- Ruby 2.3.3

PHP

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16phpall:v5.8.2 - Docker Hub,
- Github
- 5.6.31
- 7.0.22
- 7.1.7
- Common components
- phpenv 1.1.1-2-g615f844
- Java 1.8.0
- Node 7.10.0
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14phpall:v5.8.2 - Docker Hub,
- Github
- 5.6.31
- 7.0.22
- 7.1.7
- Common components
- phpenv 1.1.1-2-g615f844
- Java 1.8.0
- Node 4.8.3
- Ruby 2.3.3

Clojure

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16cloall:v5.8.2 - Docker Hub,
- Github
- 1.3.0
- 1.4.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.8.0
- Common components
- leiningen
- Java 1.8
- Node 7.x
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14cloall:v5.8.2 - Docker Hub,
- Github
- 1.3.0
- 1.4.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.8.0
- Common components
- leiningen
- Java 1.8
- Node 7.x
- Ruby 2.3.3

Scala

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16scaall:v5.8.2 - Docker Hub,
- Github
- 2.9.3
- 2.10.6
- 2.11.11
- 2.12.3
- Common components
- sbt
- Java 1.8.0
- Node 7.10.0
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14scaall:v5.8.2 - Docker Hub,
- Github
- 2.9.3
- 2.10.6
- 2.11.11
- 2.12.3
- Common components
- sbt
- Java 1.8.0
- Node 4.8.3
- Ruby 2.3.3

C/C++

OS Image Link Language versions Additional packages
Ubuntu 16.04 drydock/u16cppall:v5.8.2 - Docker Hub,
- Github
- gcc 7.1
- clang 4.0.0
>- Common components
- Java 1.8.0
- Node 7.10.0
- Ruby 2.3.3
Ubuntu 14.04 drydock/u14cppall:v5.8.2 - Docker Hub,
- Github
- gcc 7.1
- clang 4.0.0
- Common components
- Java 1.8.0
- Node 4.8.3
- Ruby 2.3.3